• 分享

    宝塔线(副图)指标及选股公式

    2016-05-14  知博陋室   |  转藏
       


         宝塔线(副图)指标及选股公式


        {宝塔线K线——宝塔线(副图)指标}
     
        {使用方法:黄托底买进,绿压顶卖出。}


        MA5:MA(C,5),COLORWHITE;
        X:=(3*C+L+O+H)/6;
        多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
        +13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
        +7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
        REF(X,20))/210,COLORMAGENTA,LINETHICK1;
        拐头:=DRAWTEXT(LONGCROSS(REF(MA5,0),REF(MA5,1),5),LOW-1,'●')COLORRED;
        翻红:=DRAWTEXT(LONGCROSS(MA5,多空线,5),LOW-1,'●')COLORMAGENTA;
        标识01:STICKLINE(REF(多空线,1)<多空线,多空线,REF(多空线,1),3,1),COLORRED;
        标识02:STICKLINE(REF(多空线,1)>多空线,多空线,REF(多空线,1),3,1),COLORCYAN;
        VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
        VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        标识03:STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
        VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3.2,1),COLORRED;
        VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
        VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        标识04:STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
        VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3.2,0),COLORFFCC66;
        VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
        VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
        标识05:STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3.2,1),COLORYELLOW;
        VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
        VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
        标识06:STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,2),COLOR00FF00{98FD};
        标识07:STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLORYELLOW;
        标识08:=STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLOR00C8FF;
        标识09:=STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ECFF;
        标识10:=STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR10FFFF;
        标识11:=STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR10F0FF;
        标识12:STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLORGREEN;
        标识13:=STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLOR93FFD1;
        标识14:=STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR93FF22;
        标识15:=STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR24FF22;
        标识16:=STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR090FF2;



        {宝塔线K线——宝塔线(选股公式)}
     
        {选股方法:选择出黄托底的“三平底”个股}


        MA5:=MA(C,5);
        X:=(3*C+L+O+H)/6;
        多空线:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
        +13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
        +7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
        REF(X,20))/210;

        标识01:=STICKLINE(REF(多空线,1)<多空线,多空线,REF(多空线,1),3,1);
        标识02:=STICKLINE(REF(多空线,1)>多空线,多空线,REF(多空线,1),3,1);
        
        VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
        VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        标识03:=STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
        VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3.2,1);
        VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
        VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
        VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
        标识04:=STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
        VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3.2,0);
        VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
        VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
        标识05:=STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3.2,1);
        VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
        VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
        标识06:=STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,2);

        标识07:STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3.2,0);
        标识08:=STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3.2,0);
        标识09:=STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0);
        标识10:=STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),1,0);
        标识11:=STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),0,0);

        标识12:=STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0);
        标识13:=STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0);
        标识14:=STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2,0);
        标识15:=STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1,0);
        标识16:=STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0,0);




      本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。
      转藏 全屏 打印 分享 献花(0

      0条评论

      发表

      请遵守用户 评论公约

      类似文章 更多

      正在播放音乐学院女神在酒店